WebStore

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

WebStore

Wicus
Hi,

I have two copies of OFBiz running on two different computers. (both Linux)

The one is installed with the DEMO data, whereas the other is not (A "clean" installation)

I work mostly on the "clean installaton" and refer to the DEMO installation for help.

Currently I simply can't get a store "connected" to a website....
 (refering to the "clean installation" from this point forward)

1.) I created "Web Site Id" : eCommerce
and selected my store under "Product Store Id"
2.) Then went to the <Content> Appheader and created "Content Id" eCommerceContent with "Content Type Id" Publish Point. "Status ID" is set to Available
3.) Under Content - WebSites - Content I add "Content Id" eCommerceContent as a Publish Point

Yet I still cannot get my store reflected in the website when connecting to https://localhost:8443/ecommerce

I got it working once in the past, yet after a restore to previous data, can't get it going again...

The webstore states "No Product Store" at the top of the page.




In addition, can someone please elaborate on the CMS acronym and it meaning. Could I be missing something in this department.

Thanks

Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Bilgin Ibryam
On Mon, 2008-11-10 at 07:17 -0800, Wicus wrote:

> Hi,
>
> I have two copies of OFBiz running on two different computers. (both Linux)
>
> The one is installed with the DEMO data, whereas the other is not (A "clean"
> installation)
>
> I work mostly on the "clean installaton" and refer to the DEMO installation
> for help.
>
> Currently I simply can't get a store "connected" to a website....
> :-( (refering to the "clean installation" from this point forward)
>
> 1.) I created "Web Site Id" : eCommerce
> and selected my store under "Product Store Id"
> 2.) Then went to the <Content> Appheader and created "Content Id"
> eCommerceContent with "Content Type Id" Publish Point. "Status ID" is set to
> Available
> 3.) Under Content - WebSites - Content I add "Content Id" eCommerceContent
> as a Publish Point
>
> Yet I still cannot get my store reflected in the website when connecting to
> https://localhost:8443/ecommerce
>
> I got it working once in the past, yet after a restore to previous data,
> can't get it going again...:,(
>
> The webstore states "No Product Store" at the top of the page.
>
>
>
>
> In addition, can someone please elaborate on the CMS acronym and it meaning.
> Could I be missing something in this department.
>
> Thanks
>
>


Did you add your webSiteId in web.xml?
You don't need CMS stuff to have a website and store working.

Bilgin

Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Pranay Pandey-2
In reply to this post by Wicus
You will have to set webSiteId in your web.xml file, and then will  
need to restart the server, because it sets context-param to  
application attribute with name [webSiteId] and its value given there.
CMS stands for Content Management System which helps us in usually  
managing static contents over the site effectively.

Hope this helps.


Kind Regards
--
Pranay Pandey
Direct : 919826035576

On Nov 10, 2008, at 8:47 PM, Wicus wrote:

>
> Hi,
>
> I have two copies of OFBiz running on two different computers. (both  
> Linux)
>
> The one is installed with the DEMO data, whereas the other is not (A  
> "clean"
> installation)
>
> I work mostly on the "clean installaton" and refer to the DEMO  
> installation
> for help.
>
> Currently I simply can't get a store "connected" to a website....
> :-( (refering to the "clean installation" from this point forward)
>
> 1.) I created "Web Site Id" : eCommerce
> and selected my store under "Product Store Id"
> 2.) Then went to the <Content> Appheader and created "Content Id"
> eCommerceContent with "Content Type Id" Publish Point. "Status ID"  
> is set to
> Available
> 3.) Under Content - WebSites - Content I add "Content Id"  
> eCommerceContent
> as a Publish Point
>
> Yet I still cannot get my store reflected in the website when  
> connecting to
> https://localhost:8443/ecommerce
>
> I got it working once in the past, yet after a restore to previous  
> data,
> can't get it going again...:,(
>
> The webstore states "No Product Store" at the top of the page.
>
>
>
>
> In addition, can someone please elaborate on the CMS acronym and it  
> meaning.
> Could I be missing something in this department.
>
> Thanks
>
>
> --
> View this message in context: http://www.nabble.com/WebStore-tp20421856p20421856.html
> Sent from the OFBiz - User mailing list archive at Nabble.com.
>

Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Wicus
In reply to this post by Bilgin Ibryam
Thanks for the reply guys.

Yes, I have the WebSiteId set in /applications/ecommerce/webapp/ecommerce/WEB-INF/web.xml within <param-value>eCommerce</param-value>.

I have stopped and restarted ofbiz, yet with no luck .... Do I need to restart the box ? Will be trying right now...
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Wicus
Apologies.... it is working. (after a restart of ofbiz)

My categories is just not showing at present. I believe it to be due to no parent category configuration at present.

I am getting a "No PROMOTION Category" displayed at the top, rather than the "No store configured" message.

Thanks a million.
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Wicus
In reply to this post by Pranay Pandey-2
Thanks

What is the best practice to delete an website ? Thereby removing it totally from OFBIZ.
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Pranay Pandey-2
In reply to this post by Wicus
You need to have a look at DemoProduct.xml file for setting up catalog  
for your product store.

Thanks & Regards
--
Pranay Pandey
Manager, Enterprise Software Development
HotWax Media Pvt. Ltd.
[hidden email]
www.hotwaxmedia.com

Office : +917314093684
Direct : +919826035576

On Nov 11, 2008, at 4:18 PM, Wicus wrote:

>
> Apologies.... it is working. (after a restart of ofbiz)
>
> My categories is just not showing at present. I believe it to be due  
> to no
> parent category configuration at present.
>
> I am getting a "No PROMOTION Category" displayed at the top, rather  
> than the
> "No store configured" message.
>
> Thanks a million.
> --
> View this message in context: http://www.nabble.com/WebStore-tp20421856p20437110.html
> Sent from the OFBiz - User mailing list archive at Nabble.com.
>

Reply | Threaded
Open this post in threaded view
|

Re: WebStore

BJ Freeman
In reply to this post by Wicus
you are working with a relational database.
it is not easy to delete records.

the best is to clean the database and start over

now if you don't mind it being in there but want to show another one on
the eccommerce side, then just create the website and product store,
then assign the new website to the web.xml.


Wicus sent the following on 11/11/2008 3:01 AM:
> Thanks
>
> What is the best practice to delete an website ? Thereby removing it totally
> from OFBIZ.
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

BJ Freeman
or you can create a new product store and link it to that website.


BJ Freeman sent the following on 11/11/2008 3:11 AM:

> you are working with a relational database.
> it is not easy to delete records.
>
> the best is to clean the database and start over
>
> now if you don't mind it being in there but want to show another one on
> the eccommerce side, then just create the website and product store,
> then assign the new website to the web.xml.
>
>
> Wicus sent the following on 11/11/2008 3:01 AM:
>> Thanks
>>
>> What is the best practice to delete an website ? Thereby removing it totally
>> from OFBIZ.
>
>
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Pranay Pandey-2
and that can be done from http://localhost:8080/catalog/control/main
Stores --> Create New Product Store -- > Web Sites

Kind Regards
--
Pranay Pandey
Direct : 919826035576

On Nov 11, 2008, at 4:52 PM, BJ Freeman wrote:

> or you can create a new product store and link it to that website.
>
>
> BJ Freeman sent the following on 11/11/2008 3:11 AM:
>> you are working with a relational database.
>> it is not easy to delete records.
>>
>> the best is to clean the database and start over
>>
>> now if you don't mind it being in there but want to show another  
>> one on
>> the eccommerce side, then just create the website and product store,
>> then assign the new website to the web.xml.
>>
>>
>> Wicus sent the following on 11/11/2008 3:01 AM:
>>> Thanks
>>>
>>> What is the best practice to delete an website ? Thereby removing  
>>> it totally
>>> from OFBIZ.
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Wicus
Thanks once again guys.

Could you also please enlighten me on what is set where to show the categories within the webstore, once the catelog is selected.

Mine just isn't showing.... (within the webstore)

Should I <Catalog> - Select a Catalog - <Categories>, I can adjust categories on the catalog which reflects immediately on the webstore.

Once a catalog is selected within the webstore, it does not however reflect the available categories in the left bar of the webstore....
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Wicus
In reply to this post by Pranay Pandey-2
Am I correct in my following logic ?

Create a category which is a category of the particular catalog (No specific name - ie. Parent)

Within this newly created category select <ROLLUP> and add the categories you wish to see in the webstore under "Category Rollup : Child Categories"

Now the webstore will happely reflect these categories once you select the catalog.

Could someone please gimme more insight into the "rollup" feature ?

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: WebStore

Pranay Pandey-2
Yes thats right for more details If you will refer to DemoProduct.xml  
file, will be of real help for you.

Thanks & Regards
--
Pranay Pandey
Direct : 919826035576

On Nov 11, 2008, at 7:34 PM, Wicus wrote:

>
> Am I correct in my following logic ?
>
> Create a category which is a category of the particular catalog (No  
> specific
> name - ie. Parent)
>
> Within this newly created category select <ROLLUP> and add the  
> categories
> you wish to see in the webstore under "Category Rollup : Child  
> Categories"
>
> Now the webstore will happely reflect these categories once you  
> select the
> catalog.
>
> Could someone please gimme more insight into the "rollup" feature ?
>
> Thanks
> --
> View this message in context: http://www.nabble.com/WebStore-tp20421856p20440176.html
> Sent from the OFBiz - User mailing list archive at Nabble.com.
>