[OFBiz] Users - forcing a specific https host for each web site

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[OFBiz] Users - forcing a specific https host for each web site

Helmut Eggebert
Hi Users,

I have OFBiz running well in one instance with multiple stores using
multiple WebSite and Store entities as well as configs to httpd.conf,
workers2.properties, webapp web.xml and the ecommerce ofbiz-component.xml.

I also have ssl working well with test certs where the host is the same for
http and https.  However, for the multiple stores I need to use a wildcard
ssl cert that works with different http and https hosts this way:

1) Store 1 at Website 1 at http://www.foo1.com/store and
https://foo1.securecertdomain.com/store
1) Store 2 at Website 2 at http://www.foo2.com/store and
https://foo2.securecertdomain.com/store

I could get this working if I could get each WebSite entity to force a
specific https host.  However, I when I go to Content Manager -> Edit Web
Site and put the host (ex. foo1.securecertdomain.com ) in the field labeled
Https Host and submit the form, nothing seems to change in terms of the host
the Web Site uses.  This is the same if I change the Enable Https select box
to Y.

What is the host field in this form supposed to affect?  Is it broken or am
I looking for the wrong affect by this form?  What is the best way to get
each Web Site to force a specific host for https?

Thanks in advance!

_________________________________________________________________
Don’t just search. Find. Check out the new MSN Search!
http://search.msn.click-url.com/go/onm00200636ave/direct/01/

 
_______________________________________________
Users mailing list
[hidden email]
http://lists.ofbiz.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [OFBiz] Users - forcing a specific https host for each web site

Andrew Sykes
Helmut,

I'm not sure if this functionality would work in conjunction with
Apache2/mod_jk.

Maybe someone has tried this? I'd be interested to hear...
--
Andrew Sykes <[hidden email]>
Sykes Development Ltd

 
_______________________________________________
Users mailing list
[hidden email]
http://lists.ofbiz.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [OFBiz] Users - forcing a specific https host for each web site

Andrew Sykes
I meant to say, have you tried this with the app server de-coupled from
mod_jk?
--
Andrew Sykes <[hidden email]>
Sykes Development Ltd

 
_______________________________________________
Users mailing list
[hidden email]
http://lists.ofbiz.org/mailman/listinfo/users